Issue with Return Addresses for Chit Chats US Edge
Incident Report for Chit Chats
Resolved
This incident has been resolved by our partner on Friday August 2. Custom U.S. return address will be displayed as before on Chit Chats US Edge label.
Posted Aug 06, 2024 - 12:01 EDT
Investigating
We are aware of an issue with incorrect return addresses showing on Chit Chats US Edge postage. Thank you for your patience as our team investigates this incident. We apologize for any inconvenience and hope to provide more details shortly.
Posted Aug 02, 2024 - 11:23 EDT
This incident affected: Web applications (Shipments and Postage).