Issue purchasing USPS postages
Incident Report for Chit Chats
Resolved
Between 16:22 EST and 16:39 EST some clients were unable to purchase USPS postages. The issue has now been resolved by our postage partner. We are monitoring the situation and expect the issue to be completely resolved. If you are still encountering problems purchasing USPS postages, please reach out to our Client Support team.
Posted Feb 27, 2024 - 16:57 EST
This incident affected: Web applications (Shipments and Postage).