Canada Post API issue affecting postage purchase and printing of labels
Incident Report for Chit Chats
Resolved
This incident has been resolved and service is back to normal.
Posted Jun 02, 2021 - 14:18 EDT
Identified
Canada Post is currently experiencing a service disruption that will affect our ability to buy postage or print labels. We will update this when resolved.
Posted Jun 02, 2021 - 13:36 EDT
This incident affected: Shipments and Postage.