Issues Purchasing Postage
Incident Report for Chit Chats
Resolved
This issue has been resolved. Thank you again for your patience.
Posted May 04, 2023 - 17:27 EDT
Monitoring
Thank you for your patience. A fix is in place to resolve the issue and postage rates are being generated as expected. We will continue to monitor for any lingering issues.
Posted May 04, 2023 - 16:52 EDT
Identified
We have identified issues with purchasing U.S. and Canadian postage on the Chit Chats platform. Thank you for your patience as our team is works closely with our partners on a resolution. We apologize for the inconvenience and hope to provide more details on a fix shortly.
Posted May 04, 2023 - 16:29 EDT
This incident affected: Web applications (Shipments and Postage).