Issues Purchasing Chit Chats U.S. Tracked Postage
Incident Report for Chit Chats
Resolved
We have confirmed that purchasing Chit Chats U.S. Tracked postage works as expected once again. Thank you for your patience and understanding.
Posted Apr 10, 2023 - 15:58 EDT
Monitoring
We've released a fix for the issue with purchasing postage and are closely monitoring for any persisting errors. You should now be able to reattempt purchasing postage for your impacted Chit Chats U.S. Tracked shipments. However, if you encounter any lingering errors, please report them to our support team. Thank you for your patience.
Posted Apr 10, 2023 - 15:25 EDT
Identified
Our team has identified an issue with buying postage for some Chit Chats U.S. Tracked shipments and we are currently working on a fix. We hope to have the issue resolved shortly and will share updates on our progress.
Posted Apr 10, 2023 - 14:54 EDT
This incident affected: Web applications (Shipments and Postage).