Issue Purchasing U.S. Postage

Incident Report for Chit Chats

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 17:49 EST

Investigating

The issue has now been resolved.
Le problème est maintenant résolu.

____

We are investigating an issue with purchasing U.S. postage on the platform. We apologize for the inconvenience and will provide another update when the postage is available.

Nous enquêtons actuellement sur un problème lié à l'achat de timbres américains sur la plateforme. Nous sommes désolés des inconvénients et vous tiendrons informé(e) dès qu’il sera accessible.
Posted Feb 18, 2026 - 17:46 EST
This incident affected: Web applications (Web Application and API, Shipments and Postage).