Delays buying postage
Incident Report for Chit Chats
Resolved
Postage purchasing should be back to normal now. A fix for the cause of the slowdown was already being developed and we will deploy it when safe to do so.
Posted Jun 08, 2020 - 16:51 EDT
Identified
Our system is backed up trying to purchase postage due to some very unusually large imports this morning that we are slowly processing. We are working on a fix.
Posted Jun 08, 2020 - 15:59 EDT
This incident affected: Web Application and API and Shipments and Postage.