Payment processor is partially down
Incident Report for Chit Chats
Resolved
Our payment card processor reports their systems are back to fully functional. We see our job backlog shrinking quickly and we should be caught up in a few minutes.
Posted May 11, 2020 - 13:04 EDT
Identified
Our payment card processor is experiencing an operational problem that is interfering with our ability to process payments. It appears to be a partial outage only. We are monitoring for updates.
Posted May 11, 2020 - 12:45 EDT
This incident affected: Web applications (Shipments and Postage).