Issue Purchasing Chit Chats US Select Postage

Incident Report for Chit Chats

Resolved

This issue has been resolved. To purchase previously failed shipments, please duplicate shipment and repurchase.
Posted Mar 24, 2025 - 18:33 EDT

Investigating

There is a known issue affecting Chit Chats U.S. Select postage purchases. Our partner is actively investigating and working on a solution. Thank you for your understanding.
Posted Mar 24, 2025 - 17:03 EDT
This incident affected: Web applications (Shipments and Postage).