Issue Printing Chit Chats US Edge Postage
Incident Report for Chit Chats
Resolved
We have identified an issue with printing Chit Chats US Edge postage. Our team has resolved the problem, and existing labels should be accessible to print by refreshing the browser page. We apologize for any inconvenience.
Posted Aug 20, 2024 - 14:38 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 20, 2024 - 14:37 EDT
Identified
We have identified an issue with printing Chit Chats US Edge postage. Our team has resolved the problem, and existing labels should be accessible to print by refreshing the browser page. We apologize for any inconvenience.
Posted Aug 20, 2024 - 14:37 EDT
This incident affected: Web applications (Shipments and Postage).