Issues Purchasing Canadian Postage Types
Incident Report for Chit Chats
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 23:29 EDT
Identified
We have identified issues with purchasing Chit Chats Canada Tracked and Chit Chats Slim postage on the platform. Thank you for your patience as our team awaits updates from our postage partner. We apologize for the inconvenience and hope to provide more details on a fix shortly.
Posted Jun 01, 2023 - 15:09 EDT
This incident affected: Web applications (Shipments and Postage).