Issue with Importing Shipments from Connected Stores

Incident Report for Chit Chats

Resolved

Our team has resolved the issue affecting importing shipments from connected stores. You may now reattempt imports from your stores to purchase postage. We apologize for any inconvenience.
Posted May 12, 2025 - 13:11 EDT

Identified

Our team has identified an issue with importing shipments from connected stores due to country of origin. We are actively working on a fix with more updates to follow soon. Thank you for your patience.
Posted May 12, 2025 - 11:02 EDT
This incident affected: Web applications (Shipments and Postage).