Issue Purchasing Chit Chats U.S. Select Postage

Incident Report for Chit Chats

Investigating

We have identified an issue with purchasing Chit Chats U.S. Select postage on the platform. Thank you for your patience as our team investigates this matter with our postage partner. We apologize for the inconvenience and hope to provide more details on a fix shortly.

Nous avons identifié un problème lors de l’achat d’affranchissement Chit Chats É.-U. Sélection sur la plateforme. Merci de votre patience pendant que notre équipe examine la situation avec notre partenaire en affranchissement. Nous sommes désolés pour ce contretemps et espérons vous fournir plus de détails sur une solution sous peu.
Posted May 20, 2025 - 16:22 EDT
This incident affects: Web applications (Shipments and Postage).