U.S. Postage Temporarily Disabled for DDP Transition

Incident Report for Chit Chats

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 19:04 EDT

Update

As of today, Wednesday, Aug 27 at 4:00 PM PST, DDP postage has been enabled for all countries. Learn more in our blog post - https://chitchats.com/blog/faq-suspension-of-de-minimis
Posted Aug 27, 2025 - 19:02 EDT

Investigating

For Chit Chats clients in the Alberta and Atlantic region only:

U.S. postage will be temporarily disabled as we prepare to transition to DDP (duties paid) postage. DDP postage for all countries will be available tomorrow afternoon and we will notify you and update this status once it is live on the platform.

Thanks for your patience and understanding.
Posted Aug 26, 2025 - 18:07 EDT
This incident affected: Web applications (Web Application and API, Shipments and Postage).