Issue with Importing Shipments and Purchasing Postage
Incident Report for Chit Chats
Resolved
The issues with importing shipments and purchasing postage have been identified and resolved. Thank you for your patience during this incident.
Posted Mar 25, 2024 - 10:29 EDT
Investigating
We have identified issues with purchasing postage and importing shipments on the platform. Thank you for your patience as our team investigates this incident. We apologize for the inconvenience and hope to provide more details shortly.
Posted Mar 25, 2024 - 09:15 EDT
This incident affected: Web applications (Shipments and Postage).