Issue purchasing USPS First Class Mail International
Incident Report for Chit Chats
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 18:17 EST
Identified
We have identified issues with purchasing USPS First Class Mail International on the platform. Thank you for your patience as our team awaits updates from our postage partner. We apologize for the inconvenience and hope to provide more details on a fix shortly.
Posted Nov 10, 2023 - 19:21 EST
This incident affected: Web applications (Shipments and Postage).