Canada Post API issue affecting postage purchase and printing of labels
Incident Report for Chit Chats
Resolved
Canada Post is still reporting an issue but our job backlog has cleared. We believe this is resolved.
Posted May 25, 2021 - 22:19 EDT
Identified
Canada Post is currently experiencing a service disruption that will affect our ability to buy postage or print labels. We will update this when resolved.
Posted May 25, 2021 - 21:26 EDT
This incident affected: Shipments and Postage.