Problem printing client batch labels

Incident Report for Chit Chats

Resolved

This incident regarding issues with printing client batch labels has been resolved.
Posted Oct 18, 2022 - 17:46 EDT

Investigating

We are currently investigating reports of clients experiencing issues with printing client batch labels. We hope to have the issue resolved as quickly as possible. We will report updates on this page as information becomes available.
Posted Oct 18, 2022 - 15:44 EDT
This incident affected: Web applications (Shipments and Postage).