Chit Chats site outage

Incident Report for Chit Chats

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 19:47 EDT

Monitoring

The Chit Chats web site was very slow and mostly unusable for about 20 minutes today around 4 pm EDT. We have implemented a fix and will be monitoring.
Posted Apr 13, 2026 - 16:53 EDT
This incident affected: Web applications (Web Application and API).