Postage Purchase Issue (Connect & SmartDrop Canada Post labels)

Incident Report for Chit Chats

Resolved

Thank you for your patience - the issue has now been resolved.

Merci de votre patience – le problème est maintenant résolu.
Posted Jun 23, 2026 - 12:25 EDT

Investigating

Our team is currently investigating an issue with purchasing postage for Chit Chats Connect and SmartDrop Canada Post labels.

Notre équipe enquête actuellement sur un problème lié à l'achat d'affranchissements pour les étiquettes Chit Chats Connect et SmartDrop de Postes Canada.
Posted Jun 22, 2026 - 18:41 EDT
This incident affected: Web applications (Web Application and API, Shipments and Postage).