Issue with postage purchase and address verification
Incident Report for Chit Chats
Resolved
EasyPost account issue is resolved.
Posted 14 days ago. Nov 29, 2018 - 14:28 EST
Update
We are continuing to investigate this issue.
Posted 14 days ago. Nov 29, 2018 - 13:51 EST
Investigating
We are currently having issue with our EasyPost account which is used for purchasing postage and address verification.
Posted 14 days ago. Nov 29, 2018 - 13:51 EST
This incident affected: Web Application and API and Shipments and Postage.