Cannot purchase postage for shipments to select destination countries
Incident Report for Chit Chats
Resolved
The issue has now been resolved.
Posted about 1 year ago. Mar 13, 2018 - 14:07 EDT
Identified
Starting Friday, Mar 9th, we are experiencing issues that prevent clients to purchase postage for shipments to select destination countries.

The issue has been identified and a solution is being developed. An update will be provided by tomorrow at 12:00 PM Pacific Time.
Posted about 1 year ago. Mar 12, 2018 - 23:38 EDT