Unable to purchase USPS letter postage
Incident Report for Chit Chats
Resolved
This issue has been resolved by our postage provider. If you are still encountering a problem with an existing shipment you can delete that shipment and recreate a new one. We apologize for the inconvenience.
Posted 3 months ago. Mar 27, 2019 - 14:53 EDT
Investigating
We are investigating a problem with clients unable to purchase USPS letter postage. Clients experiencing this error will see an error indicating that postage is unable to be purchased.
Posted 3 months ago. Mar 27, 2019 - 12:36 EDT
This incident affected: Shipments and Postage.