USPS postage currently not available for thick envelope package types
Incident Report for Chit Chats
Resolved
Our postage provider has resolved all know postage issues. We are sorry for all the inconvenience this has caused.
Posted 8 months ago. Feb 08, 2019 - 18:15 EST
Update
This issue has been resolved for USPS First Class postage. Issues with purchasing USPS Media Mail and USPS International postage types for thick envelopes still persist. Our postage provider has identified the issue and is working on a resolution.
Posted 9 months ago. Jan 28, 2019 - 16:00 EST
Update
The problem is still on-going but is limited only to shipments using the Thick Envelope (aka soft pack) package type. All other package types can purchase postage.
Posted 9 months ago. Jan 26, 2019 - 22:02 EST
Update
We are continuing to work with our USPS postage provider to resolve this issue but at this time we do not have an ETA.
Posted 9 months ago. Jan 26, 2019 - 20:50 EST
Investigating
We are investing an issue preventing USPS postage from being purchased.
Posted 9 months ago. Jan 26, 2019 - 20:22 EST
This incident affected: Shipments and Postage.